Chapter 2

Using ViSta

This chapter presents a tutorial on how to use ViSta. The tutorial covers ViSta’s
structured graphical user interface, including guidemaps, workmaps, menus and
toolbar; ViSta’s listener window; and ViSta’s data analysis language, including
scripts.
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Introduction

This chapter is a tutorial introduction to ViSta, the Visual Statistics System. When
you first run ViSta you will see two windows, one titled “ViSta WorkMap” and the
other “Listener”. Depending on startup options, you may also see ViSta’s guidemap
window, titled “Load Your Data”. The workmap and guidemap windows are ViSta’s
structured graphical user interface for statistical data analysis. The listener is ViSta
window for displaying and typing character information.
Section 2.2 teaches you how to use the guidemap window. This window contains
maps that guide you through advanced data analyses. The maps have been constructed by an expert.
Section 2.3 teaches you how to use the workmap window. Unlike a guidemap, the
workmap doesn’t exist at the beginning of the analysis. It is constructed as you
work your way through an analysis. Thus, the workmap records the steps you take
during a data analysis session. It also provides a means to revisit earlier steps in the
analysis and a way to launch new analysis ideas from earlier steps.
Section 2.4 teaches you how to use the “Listener” window. This window listens to
your analysis and displays messages about its progress. It is also the place where
you can type statements in ViDAL, ViSta’s data analysis language, and in Lisp, the
underlying language. In the MS-Windows version the Listener window is also
where help, reports and other printed information appears. (In the Macintosh version, these appear in other windows).
In addition to these windows, there are several menus on the menubar. The menus
allow you to create data analyses. Some of the menu items are paralleled by button
in the workmap’s toolbar. In this chapter we describe how to use ViSta’s guidemap,
workmap and listener windows, and how to use ViSta’s menus and toolbar.

2.2

Using GuideMaps

In this section you will follow steps in a tutorial that teaches you how to analyze
data using ViSta’s guidemap. You will also see the workmap begin to be formed,
and how it records major analysis steps.
1. Show the GuideMap. If the Load Your Data guidemap is not showing, use
the Show Guidemap item of the Command menu to show it. You will then
see the Load Your Data guidemap window.

The guidemap window contains the very simple guidemap shown in Figure 1.
This guidemap has an entry point (the top arrow), a highlighted (dark) button
named Load Data, and an exit point (the bottom arrow) which is an automatic
link to the next guidemap, one that provides data analysis guidance.
ViSta: The Visual Statistics System
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You use guidemaps by clicking on highlighted buttons. If
you click on the ?? side of a highlighted button you see
help for the button. If you click on the !! side, the button’s
action takes place. Then the button turns gray (meaning it
is inactive) and guidance flows along the connecting
arrow to the next step. In this case the next step is to see
Figure 1: A Simple
the data analysis guidemap.
Guidemap
Click on the ?? side of the Load Data button and read the
help (you may have to scroll the help to see the top of it).
The help tells you that you load data into ViSta by clicking on the !! portion of
the Load Data button. Thus, this guidemap guides you to load data, the first
step of every data analysis. You do this next.
2. Load a datafile. To load data, click on the !! side of the
Load Data button in the guidemap (Mac users may
have to move the help window aside). You will see a dialog box that opens to the data folder (Mac users may have
to find the data folder). Use this dialog box to load the
EXAMPLE1.LSP datafile (datafiles are explained
Figure 2:
below). A data icon, titled Car-Prefs , appears in the
A Data Icon
WorkMap window, as shown in Figure 2. The icon represents multivariate data, with the tiny vertical bars representing variables. More
will be said about the icon, and how it works, in section 2.3.
The new guidemap shown in Figure 3 has appeared in
the guidemap window. The window is now named
Data Analysis. This guidemap has an entry point
(the arrow at the top) which is followed by five buttons.The button named Link:Explore is highlighted
and ready to use. The middle three buttons are connected into a loop structure, indicating that transforming data, analyzing them, and looking at the resulting
model may be repeated several times.
The highlighting of the buttons in the new guidemap
guides you to the Link:Explore button. When you
click on its ?? side you will get help that explains that
this button will display a new guidemap for exploring Figure 3: Data Analdata. (Actually, you can click on the left half of any
ysis Guidemap
button for help, not just highlighted buttons). If you
click on the !! side you will see this new guidemap. (A Link : button always
takes you to a new guidemap.)
After clicking on the !! side of the Link:Explore button you will see the
Explore Your Data guidemap shown in Figure 4. We will use this guidemap
in the next step to explore data.
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3. Explore the Data. Button highlighting
of the Explore Your Data guidemap

tells you to browse your data or to
return to the guidemap you just came
from. Click on the Browse Data button to see the data. A portion of what
you see is shown in Figure 5.
These data are ratings, made by 25 people, of their preferences for each of 17
automobiles. The data are from an
unpublished 1982 study (Sarle, personal communication) in which people
rated their preference for each automobile on a scale from 0 (no preference) to
9 (strongest preference). The judges
were employees of a large statistical
software house. Most of the judges
Figure 4:
were programmers, but two of the The Guidemap for exploring data.
judges were in the marketing section,
one was the president of the company, and one was the grandmother of one of
the programmers. Looking over the list of automobiles, you will see that some
were manufactured in America, some in Europe, and some in Japan.
When you are finished looking at the data, use the close box on the datasheet
window to close the datasheet.
Notice that the selection of
active guidemap buttons has
changed: The Browse
Data button is gray, and the
Visualize Data or Summarize Data are highlighted. This means that you
are no longer guided to
browse the data (since
you’ve already done it) and
are guided to visualize or
summarize instead.
Figure 5: A Portion of the Datasheet.
Visualize the Data: Click
Visualize Data to display a visualization of the car preferences data. The
visualization consists of five windows: a scatterplot-matrix (upper left), a spinnable 3D scatterplot (upper middle), a scatterplot (lower left), a histogram
(lower middle), and a list of observation labels (right). We will explain how to
use the visualization in another chapter. For now, if you wish to explore how the
windows work, go right ahead. Then, close the visualization by clicking the
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close box of the scatterplot-matrix. It will close all visualization windows for
you.
Summarize the Data: After you close the data visualization you will see that
the Visualize Data button has become gray because you’ve finished the visualization step. However, the Summarize Data button is still highlighted.
Clicking the Summarize Data button displays statistics that summarize the
data. You will see that the median, mean and variance of the automobiles’ preference ratings vary considerably, but that the minimums and maximums are
about the same.
If you are using a Macintosh you should close the summary window before proceeding to the next steps.
Note that once you have used a highlighted button, it
turns gray, indicating that it is no longer a step that you
are guided to do. Also note that after you have used both
the Visualize Data and Summarize Data buttons,
the List Observations and List Variables buttons
become highlighted, indicating that you are now guided
to take these next two steps.
4. Subset the Data: We now are guided to display the
observation and variable windows. Click on these two
buttons to see observation labels and variable names.
Note that after you do this the next two guidemap buttons
are highlighted.The variables and observations windows
can be used for subsetting the data. We will do this to
select a subset of people for later analysis.
To select a subset of the people you must first click on
the Obs window to make it the active window. Then,
drag your cursor over pgmr1 through pgmr10. These
observations become highlighted, as in Figure 6. Now,
stretch out the window or scroll to the end of the list of
labels. Next, shift-drag (hold down the shift key, then
drag your mouse) over the last three people. They are
labeled Mktng1, GrndMa and Mktng2. Now two
groups of people will be highlighted. The window should
now look like Figure 6. These are the selected observations that will be included in the next step.
Figure 6:
5. Create Data Subset: Next you will use the Create
Data guidemap button to create a new dataset using the Subsetting Data
selections you just made in the observations window.
Click the Create Data button. When the dialog box appears it suggests the
name Created-From-Car-Prefs. Change the name by selecting the text,
typing subset and clicking OK. A new data icon named subset appears in
the workmap, which now looks like Figure 7. Notice that the top icon is highViSta: The Visual Statistics System
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lighted, indicating it is still the “current” data. Also notice that the name of the
bottom button in the guidemap has changed from GoTo:New Data to
GoTo:subset.
Now, while watching the two data icons, click on the
GoTo:subset button in the guidemap. This changes the
highlighting of the workmap to match that shown in Figure 8. This highlighting indicates that the new dataset is
now the current one. Also, a new Save Your Data
guidemap has appeared in the guidemap window. We will
get to it in a moment.
Figure 7:
The most important thing to note about the workmap’s Car-Prefs are the
new subset data icon is that it is connected to the Carcurrent data.
Prefs icon by an arrow. The arrow indicates that the
subset data is derived from the CarPrefs data. The
purpose of the workmap is to present a visual map of the series of steps you take
during a data analysis session, and to show how various statistical objects (i.e.,
datasets, data models and data analysis procedures) are derived from other
objects by the operations and analyses you perform during the session. The
icons show the steps, and the arrows show the flow of steps.
Note that the variable window now lists only the subset of
selected variables. Also, a check-marked menu item has
been added to the bottom of the data menu. The highlighted icon in the workmap and the check-marked item in
the menu show that the subset data are the “current”
data.
It is important to understand that the guidemap you now
Figure 8:
see is for the subset data, not for the Car-Prefs data.
Subset is the
You can demonstrate that this is the case by clicking on
current data.
the Car-Prefs icon in the workmap. When you do this,
the guidemap changes back to the one guiding the analysis of the Car-Prefs
data (its the one that you just used to create the subset data).
Click on this guidemap’s Return button. You return to the Data Analysis
guidemap for Car-Prefs . Notice that the button-highlighting on this
guidemap has changed to reflect the fact that you have finished exploring the
Car-Prefs data, and are ready to either transform or analyze these data. Also
notice that the guidemap for the subset data (which you can see by clicking on
the subset data icon in the workmap), still shows that you need to explore
these data.
You are now finished with the guidemap tutorial. Please close the guidemap window and proceed on to the next section, which presents the workmap tutorial. At
some later time you might wish to proceed from here using guidemaps to see how
you would continue the analysis using their guidance.
ViSta: The Visual Statistics System
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2.3

Using WorkMaps

So far, you have learned how to have ViSta’s guidemaps guide you through the initial stages of a data analysis. Along the way you have seen a workmap begin to
form in the workmap window. In this section you load in a new dataset and learn
how to analyze it (and the previous dataset) using ViSta’s workmap, menus and
toolbar. You will continue to see the workmap form and see how it records the steps
in your analysis. Finally, you will use the workmap to return to a preceding analysis
step to pursue new analysis directions.
6. Load another datafile. Use the File menu’s Open Data item to open the

EXAMPLE2.LSP datafile (opening a datafile is the same as loading it and then
browsing it). You will see a datasheet of the new data, part of which is shown in
Figure 9. The new dataset is about the same 17 automobiles as those in the pre-

Figure 9: Part of the Datasheet for the Car Ratings data.

vious dataset. However, the new data is ratings, by a consumer organization, of
the automobiles on 10 scales. The scales rate quality on a 1 to 5 scale (5 is best).
Close the datasheet when you have finished looking at the data.
When you close the datasheet you will see that the workmap now has three
icons on it, as is shown in Figure 10. There is a new CarRatings icon for the
newly opened datafile. This icon is not connected to any previous icon, indicating that the data are independent from the previous sets of data. The new icon is
highlighted (dark), indicating it is the current data.
Clicking on an icon in various ways has various
effects. A single click on an unselected (light)
icon selects the icon, changing its highlighting
and making the icon’s data the current data. A
double click on an icon opens it to show its
datasheet.1 You can drag icons to a new location
by placing your cursor on an icon, pressing your
Figure 10:
mouse button down, and dragging to a new locaThree Data Icons
tion while holding down the button. You can also
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drag icon-trees (an icon and all the icons attached below it) by holding down the
shift key before dragging. Try each of these to see how they work.
You may have noticed that the Data, Transform, and Analyze menus are
highlighted and ready to use. If you look at the Data menu, you will see that
there are Car-Prefs, subset, and CarRatings menu items at the end. One
of these items is check-marked. The check-mark in the menu corresponds to the
highlighted icon. These are two different ways of showing you that these data
are the “current” data. One and only one data object is the current data.
Use the menu to make the CarRatings data the current data. Notice how the
highlighting of icons changes.
7. Explore the Data. You explore data by using items of the Data menu, especially the Visualize Data, and Summarize Data items. The Browse
Data, List Variables, and List Observations can also be used to produce
windows which give you details of the data. Each menu item has the same
action as the guidemap button with the same name, except that some menu
items give you a choice of options, whereas guidemap buttons always give you
the default option. We don’t explain how to use these menu items in detail here,
since there were already explained in section 2.2. However, since these are different data than were used in section 2.2, you should use these menu items to
explore these data.
8. Normalizing Data.At this point you will normalize the CarRatings data. You
do this by selecting the data (clicking on its icon) and choosing the Transform
menu’s Normalize Data item. This gives you a dialog box with options for
normalizing the data. The default options, which normalize variables to have a
mean of zero and a standard-deviation of 1, are appropriate, so simply click
“OK”.
As shown in Figure 11, two icons are added to the
workmap: First, the Norm procedure icon, is connected to the CarRatings icon, then the NormCarRatings data icon is connected to the procedure icon. The procedure icon is a short and wide
icon containing mathematical symbols. These
symbols represent the mathematical nature of an
analysis procedure. The arrows that connect the
three icons indicate that the ratings data have
Figure 11: Workmap
flowed through the normalization procedure,
after normalizing
which produces a new dataset of normalized ratings. You can use the Summarize Data menu

1. The Macintosh workmap provides popup menus. An option-click on an icon
shows a popup menu of things that can be done with that icon. An option-click on
the workmap background shows a menu of things that can be done on the workmap.
ViSta: The Visual Statistics System
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item if you wish to check the normalization (variable means should be zero and
standard deviations should be one).
9. Transpose Data. You now return to the subset data to transpose it in preparation
for a “preference mapping” analysis (?????). A preference mapping analysis is a
principal component analysis of data where the variables are the people making
the preference ratings, and the observations are the things being rated (automobiles, in this case). This is the transpose of the normal way data are arranged.
For this reason we must transpose our data.
First, click on the subset data to make it the
current data. Then, to transpose the data,
choose Transpose Data from the Transform menu. Now the workmap should look
like Figure 12. Note that two icons have been
added to the workmap, like with the normalization step. We have a new procedure icon
(named Trnsps ) and a new data icon
(named Trnsps-subset ). As before, these
icons represent the flow of data, this time of
the subset data through the transpose procedure into the new, transposed subset data.
Figure 12:
Double clicking Trnsps-subset will open
Workmap
after Transposing
its datasheet, revealing that there are now 14
variables, which are the judges, and 17 observations, which are the automobiles. Close the datasheet when you are finished
looking at it.
10. The Toolbar. By choosing the Command menu’s Show Toolbar item, you
can add a toolbar to the workmap (if the toolbar isn’t showing, use the menu
item to display it now). The toolbar is shown below. The first toolbar button

Figure 13: ViSta’s toolbar.

gives help about the workmap. The rest of the buttons provide access to ViSta’s
analysis procedures. Buttons that have math symbols in them are active and
ready to use. Buttons that are gray are not active. Clicking on an active button is
the same as choosing the corresponding item from the Analyze menu (button
names are abbreviations of menu items in the Analyze menu). The toolbar can
be hidden by choosing the Command menu’s Hide Toolbar item.
11. Analyze the Transposed Data. You will now perform a principal component
analysis of the transposed data. To do this choose the Analyze menu’s Principal Components item (or click on the toolbar’s “PrnCmp” button). The procedure's icon, named PrnCmp , is added to the workmap. It is connected to the
subset data icon, indicating that the data are “flowing” into the analysis proce-
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dure. A dialog box appears to allow you to set procedure options. The default, to
analyze correlations, is appropriate, so just click OK.
When the analysis is finished, a model
icon named PCA-Trnsps-subset is
added to the workmap. You may have to
scroll the workmap window to see it. The
workmap now looks like Figure 14. This
icon is shaped like a data icon, but it has
mathematical symbols as well as variable
symbols, representing the fact that a
model is the result of applying a mathematical procedure to data. As shown in
Figure 14, the model icon is connected to
the PrnCmp procedure icon, indicating
that the data which flowed into the analysis procedure have been processed by the
procedure to produce a model of the data.
The model icon is named PCATrnsps-subset , indicating that it is a
Figure 14: Workmap after
Principal Components model of the trans- Principal Component Analysis
posed subset data.
12. Explore the Model:2 Now you can use the Model menu’s Visualize Model
and Report Model items to see the model of the data.
Visualize Model: The Model menu’s Visualize Model item produces a
visualization of the model -- a model-eye’s view of the data. Each model’s visualization is unique. The Principal Components visualization is similar to the
data visualization already discussed: There are five windows. Two of these windows are identical to data visualization windows (the scatterplot-matrix and
observation list windows). The Scree Plot is a plot of fit. It plots the eigenvalue
(a measure of fit) for each component. The spinplot and biplot (shown in Figure
15) differ from the data visualization’s spinplot and scatterplot, respectively, by
the addition of vectors, one for each variable (judge). A vector points from the
origin to the side of the space that contains observations with the highest scores
on the variable. For these data, a vector points to the side of the space which has
the automobiles most preferred by the judge.
An interesting feature of the model visualization can be seen by using the observation list window to select all of the automobiles made in Europe and Japan.
There are five of them -- two Hondas, two Volkswagens, and a Volvo. (They are
located in two groups. The selection of the second group can be added to the
already selected first group by shift-dragging the cursor over the group.) Note

2. This step assumes you are somewhat familiar with Principal Component Analysis. You
can skip this step without any loss of continuity.
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that all of the European/Japanese automobiles are located on the right side of
the biplot and spinplot. If you select all of the American automobiles you will
see that they are on the left side of the space. Since the data that are being analyzed are preference judgments, the principal components analysis is showing
us that a major aspect of preference is where automobiles are manufactured.
More exploration reveals that expensive automobiles (Cadilac and Lincoln) are
located at the bottom-left of the space, while inexpensive automobiles (Pinto,
Chevette) are located at the top-left. Thus, this is another aspect of preference.
Finally, the vectors in
the biplot and spinplot are also interesting. Since the data
are preference judgments, and since each
variable is a judge,
the vectors point
from the origin in the
most preferred direction. If you visually
project each automobile at right-angles
onto a judge’s vector,
Figure 15: Spinplot of Preference analysis,
you have the model
a Principal Components Analysis of Preferences
of that judge’s preferences. Thus, the many vectors pointing towards imported automobiles mean
that these cars are preferred by many judges. The vectors that point towards the
“five o’clock” position are for judges who prefer expensive automobiles. There
are not many judges who prefer American automobiles (only the marketing people!) nor are there many who prefer inexpensive automobiles (only the grandmother!). When you are finished, close the spreadplot.
Report Model: The Model menu’s Report Model item produces a report of
the results of the data analysis, including a list of the variables that were analyzed, of the options that were used, and all of the relevant statistics. For the
Principal Components analysis, the report includes the usual information produced by a principal components analysis, including various fit indices, eigenvectors, and scores.
13. Create Data: You can create datasets that contain the important numerical
results of analyses. You do this by selecting a model icon and then using the
Model menu’s Create Data item. Select the PCA-subset model icon and
then use the Create Data menu item. A dialog box gives you the choice of
creating three datasets, one of scores, one of coefficients, and one that is a copy
of the data that were analyzed. Set the choices so you only create scores, and
then click OK. A new dataset is created and represented by a data icon attached
to the model icon. You can use the Data menu to explore the scores.
ViSta: The Visual Statistics System
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14. Merging Data Objects. You can merge two data objects into one data object.

This can be done so that either observations or variables are merged.
Merge Variables: When you use the Data menu’s Merge Variables item,
you create a new dataset that has all of the variables from the “current” dataset
as well as all of the variables from the “previous” dataset – i.e., the one that was
current before the current one.
Take the following steps to merge the Scores-PCA-subset dataset with the
Norm-CarRatings dataset: First click on the Norm-CarRatings data
icon, to make it the “current” dataset. Then click on the Scores-PCATrnsps-subset data icon, making it the new “current” dataset and the
Norm-CarRatings dataset the “previous” dataset. Now, choose the Data
menu’s Merge Variables item, and type a name for the merged dataset like
“Ratings-and-Scores”, clicking “OK”. You will see a new data icon
appear, with lines attached to the new data set from both of the datasets that
have been merged together. The workmap will look like Figure 16.
Note that to successfully merge variables, the two datasets must have the
same number of observations (rows),
otherwise, an error message appears.
Furthermore, it generally only makes
sense to merge variables if the two
datasets have the same observations in
the same order, not only the same number of observations. ViSta, however,
does not check for this condition.
Merge Observations: The Data
menu’s Merge Observations item
works in a fashion similar to the variable merging item. The item creates a
new dataset that has observations from
the current dataset as well as observations from the previous dataset. The two
datasets must have the same number of
variables (and, usually, should have the
same variables in the same order).
15. Save Data: You can save a dataset by
using the Data menu’s Save Data
Figure 16: Workmap after
item. To do this, select the dataset you
wish to save, then use the menu item. creating and merging datasets
For this tutorial, click on the Ratings-and-Scores data icon. Then choose the Save Data menu item. You
will see a dialog box that lets you enter a name for the file the data will be saved
in. Type in the name ratscors, then, click save to save the data. Now that
ViSta: The Visual Statistics System
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you have saved these data, you can, at any later time, load these data back into
ViSta by using the Data menu’s Load Data menu item.
16. Save Model: Save the model by selecting the PCA-subset model icon and
then selecting the Model menu’s Save Model menu item. You will see a dialog box. Type pcacarpf and click Save. The model is now saved and can be
loaded in at a later time using the Load Model item.
17. Load Model: Now, load the model that you just saved back into ViSta. To do
this, use the Model menu’s Load Model item, then use the open file dialog
box to select the file you just saved. Click Open and the model will be loaded.
Notice that three new icons appear in the workmap. The first icon is a data icon
for the data being modeled. The second is a procedure icon for the principal
components analysis procedure. The third is a model icon for the model of the
data. The three icons emphasize that a model is a specific data analysis procedure’s representation of a specific set of data.
18. Hiding the Workmap. If you don't want to see the workmap, you can click its
close box. This does not destroy the session’s work structure, it only hides it. If
you want the workmap and its structure to again be visible, select the Show
Workmap item from the Command menu. Hiding the workmap improves the
response time of the system, especially when the workmap is complex.
19. Quitting ViSta. To quit the analysis session, choose the Quit item from the File
menu. ViSta will ask you if you wish to save data or models. If you do, click
Save, then use the Data menu’s Save Data item or the Model menu’s Save
Model item to save those data or models you wish to save. Then choose Quit
again, and click Quit in the dialog box.

2.4

Using ViDAL

When ViSta is run, it can show as many as three windows. Two of these, the
guidemap and the workmap, form ViSta’s structured graphical user interface. We
have demonstrated these in the preceding sections. The third is the listener window.
It will be demonstrated in this section.
ViDAL, ViSta’s Data Analysis Language, is one of ViSta’s primary features. ViDAL
lets users type at the keyboard rather than point and click at the graphical interface.
The language consists of statements which correspond to menu items. The correspondence is straight-forward: The statement is identical to the menu item, except
that spaces are replaced by dashes. For example, the Show Variables menu item
is represented in the language by the (show-variables) function. Nearly
everything that can be done by point-and-click can also be done by typing.
ViDAL can be typed into the listener window. Since everything that can be done by
menus can also be done by typing, all of the tutorial presented in sections 2.2 and
2.3 can be performed by typing in the listener window. In addition, any Lisp stateViSta: The Visual Statistics System
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ment can be typed into the listener. Since ViSta’s language consists entirely of Lisp
statements, any mixture of Lisp, Lisp-Stat and ViDAL statements can be typed, giving you keyboard access to all aspects of ViSta, Lisp and Lisp-Stat.
In this section we present the statements that can be typed to perform the tutorial in
the previous section. The step numbers and headings used in this section correspond to those in sections 2.2 and 2.3.
1. Show the GuideMap. While you can show the guidemap by typing (show2.

3.

4.

5.

6.
7.
8.
9.

guidemap), there is no reason to do this since you will not be using it.
Load a datafile. The carprefs data may be loaded from the example1.lsp
datafile by typing:
(load-data "example1")
Explore the Data. The data may be explored by typing the commands
(browse-data)
(visualize-data)
(summarize-data)
Note that the (visualize-data) function simply displays the visualization. To
visually explore the data, use the mouse to point and click on various graphs.
Subset the Data. First, you list the variable names and observation labels by
typing:
(list-observations)
(list-variables)
Then, to select the observations that were selected in the tutorial by pointing
and clicking in the observations window, you type:
(select-observations '(
"pgmr1" "pgmr2" "pgmr3" "pgmr4" "pgmr5" "pgmr6"
"pgmr7" "pgmr8" "Prsdnt" "pgmr9" "pgmr10"
"Mktng1" "GrndMa" "Mktng2"))
Create Data Subset. A new dataset, named subset, which only contains the
selected variables, can be created by typing
(create-data "subset")
Load another datafile. The carratings data are loaded by typing
(load-data "example2")
Explore the Data. The carratings data can be explored using the same
commands as those in step 3.
Normalize the Data. Type (normalize-data) followed by (summarize-data) to check on the normalization.
Transpose the Data. First, make the subset data the current data by typing
(setcd subset)
Here, setcd stands for “set current data”. Then transpose the subset data by
typing
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(transpose-data)
10. Show the Toolbar. If the toolbar isn’t showing in the workmap, type
(show-toolbar)
11. Analyze the Data. To analyze the transposed subset data type:
(principal-components :data trnsps-subset)
Alternatively you could use the setcd function to select the data that you want
to analyze, and then analyze the current data. This would involve typing
(setcd subset)
(principal-components)
12. Explore the Model. You can explore the principal components model of the
carpref data by typing
(visualize-model)
(report-model)
The (visualize-model) function simply displays the visualization. You
then must explore the data by pointing and clicking on the visualization graphs.
There are no keyboard statements that you can type to do this.
13. Create Data: You create default output datasets from the principal components
analysis by typing (create-data).
14. Merging Data Objects. You merge data objects by typing three functions:
(setcd Norm-CarRatings)
(setcd Scores-PCA-trnsps-subset)
(merge-variables "Ratings-and-Scores")
The first function sets the current-data to Norm-CarRatings . The second
function sets the current-data to scores-pca-subset and makes the previous
data Norm-CarRatings . Then the third function merges variables of the current data object with the previous data. Note that the name of the new data
object is placed in quotes, but that whenever an already existing data object is
referred to it is not placed in quotes (since Lisp-Stat knows it by its symbolic
name).
15. Save Data: You save the new data by typing
(save-data "ratscors")
This saves the current data as the indicated file.
16. Save Model: You can also save the new model by typing the following two
statements. The first expression sets the current-model to be pca-carprefs, while
the second expression saves the model:
(save-model "pcacarpf")
17. Load Model: You can load the model you just saved by typing
(load-model "pcacarpf")
18. Hiding the Workmap: You can hide the workmap by typing
(hide-workmap)
19. Quitting ViSta: Simply type (quit).
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A “script” for the analysis just presented can be formed by gathering all of the statements together and placing them into a file with a .lsp extension. In fact, the script of
the tutorial presented in this chapter has been saved in the examples folder as the
file tutorial.lsp.
You can use ViSta to load the file, using the File menu’s Load Edit menu item. It
will then perform the analysis without further interaction. This gives you the ability
to analyze a dataset without having to interact with the analysis until it is finished.
This is particularly useful when one is repeatedly applying the same analysis to
newly gathered sets of data.
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